<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Dominant defense leads Stow girls basketball past Mentor</title><meta property=og:title content="High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win"/><link rel=amphtml href=https://amp.mytownneo.com/amp/4171317001 /><meta property=article:author content="Michael Leonard"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.mytownneo.com /><link rel=preconnect href=https://user.mytownneo.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.mytownneo.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.mytownneo.com/NKNT-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z3a4c5d90e.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3b664a966.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-dfd2910d.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-454f9438.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-581ff685.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-9a7e82f6.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-9b155356.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/0ec8d784-ef54-4903-b5c5-4486a75c85f7/d0bfa0b3-ae8c-44cb-9015-18bc27a5fa66/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=6565528002" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home."/><meta property=og:description content="The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home."/><meta property=fb:pages content=893568307789841 /><meta property=fb:app_id content=893568307789841 /><link rel=canonical href=https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/ /><meta property=og:url content=https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/ /><meta property=og:site_name content=MyTownNEO /><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?crop=1680,945,x0,y204&width=1680&height=945&format=pjpg&auto=webp"/><meta property=og:image:width content=1680 /><meta property=og:image:height content=945 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?crop=1680,945,x0,y204&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@MyTownNEO /><meta name=twitter:creator content=@MyTownNEO /><meta name=twitter:title content="High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win"/><meta name=twitter:description content="The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=${tc}|H1Nav|skipToMainContent aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label=MyTownNEO data-t-l=|H1Nav|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 284.5 45.22"><path d="M15.69 32.04L4.75 9.25v26.16H0V.66h5.67l12.42 26.27L30.5.66h5.57v34.75h-4.7V9.35L20.39 32.04zM53.7 37.5c-1.09 2.72-2.41 4.69-3.96 5.9s-3.3 1.81-5.24 1.81c-1.09 0-2.09-.14-3.01-.41-.92-.27-1.62-.55-2.09-.82l1.69-3.88c.41.17.85.34 1.33.51.48.17 1.04.26 1.69.26.99 0 1.9-.26 2.73-.79a5.53 5.53 0 002.02-2.58l1.18-2.76L38.73 9.66h5.26l8.43 19.21 7.36-19.21h5.16L53.7 37.5zm22.74-2.09V5.01h-11.7V.66H93.3v4.35H81.6v30.4zm27.69.51a13.5 13.5 0 01-6.82-1.71 12.33 12.33 0 01-4.7-4.75 13.87 13.87 0 01-1.71-6.92c0-2.59.57-4.9 1.71-6.92a12.33 12.33 0 014.7-4.75 13.5 13.5 0 016.82-1.71c2.55 0 4.83.57 6.82 1.71a12.4 12.4 0 014.7 4.75 13.9 13.9 0 011.71 6.92c0 2.59-.57 4.9-1.71 6.92a12.33 12.33 0 01-4.7 4.75 13.46 13.46 0 01-6.82 1.71m0-4.34c1.6 0 3.01-.38 4.24-1.15s2.19-1.83 2.89-3.19c.7-1.36 1.05-2.93 1.05-4.7s-.35-3.34-1.05-4.7a7.91 7.91 0 00-2.89-3.19 7.81 7.81 0 00-4.24-1.15c-1.6 0-3.01.38-4.24 1.15A7.98 7.98 0 0097 17.84a10.14 10.14 0 00-1.05 4.7c0 1.77.35 3.34 1.05 4.7.7 1.36 1.66 2.43 2.89 3.19s2.64 1.15 4.24 1.15m38.22 3.83l-5.72-20.18-5.57 20.18h-5.26l-7.87-25.75h4.95l5.73 20.74 5.62-20.74h4.95l5.73 20.74 5.77-20.74h4.8l-7.87 25.75zm20.85-14.26v14.26h-4.96V9.66h4.45l.36 3.99a9.47 9.47 0 013.58-3.24 10.16 10.16 0 014.91-1.25c2.89 0 5.23.95 7 2.84 1.77 1.89 2.66 4.57 2.66 8.05v15.38h-4.96v-15.4c0-2.08-.54-3.69-1.61-4.83a5.7 5.7 0 00-4.37-1.71 6.7 6.7 0 00-3.55.97 7 7 0 00-2.55 2.68 7.96 7.96 0 00-.96 4.01m45.22 14.26l-13.64-20.03v20.03h-8.74V.66h8.68l13.6 20.39V.66h8.78v34.75zm13.79 0V.66h23.97v7.62h-14.67v5.87h13.03v7.62h-13.03v6.03h15.48v7.61zm44.25.66a18.5 18.5 0 01-9.27-2.3 16.8 16.8 0 01-6.41-6.36 18.27 18.27 0 01-2.35-9.33c0-2.66.44-5.08 1.33-7.28a16.9 16.9 0 019.5-9.48 18.87 18.87 0 017.2-1.33c2.62 0 5.02.44 7.2 1.33a17.3 17.3 0 015.72 3.76 16.85 16.85 0 013.78 5.72c.89 2.2 1.33 4.62 1.33 7.28 0 3.51-.78 6.62-2.35 9.33a16.87 16.87 0 01-6.41 6.36 18.37 18.37 0 01-9.27 2.3m0-7.87c1.67 0 3.12-.43 4.37-1.28a8.7 8.7 0 002.94-3.55 12.22 12.22 0 001.07-5.29c0-2.01-.36-3.78-1.07-5.31a8.93 8.93 0 00-2.94-3.6 7.42 7.42 0 00-4.37-1.3c-1.67 0-3.13.43-4.37 1.3a8.93 8.93 0 00-2.94 3.6 12.34 12.34 0 00-1.07 5.31c0 2.01.36 3.77 1.07 5.29a8.63 8.63 0 002.94 3.55 7.5 7.5 0 004.37 1.28"/></svg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=|H1Nav|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce gnt_n_mn_l__se" href=/sports/ data-t-l=|H1Nav|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=|H1Nav|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=|H1Nav|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=|H1Nav|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=|H1Nav|nation-world>Nation / World</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/obituaries/ data-t-l=|H1Nav|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.mytownneo.com/user/enewspaper/ data-t-l=|H1Nav|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.publicnoticesohio.com/ data-t-l=|H1Nav|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=${tc}|H1Nav|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=${tc}|H1Nav|search title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-oh-kent-weeklies-C6678-high_impact-sports-preps-basketball-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Basketball data-c-ssts=BASKETBALL></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win</h1><div class=gnt_ar_by><a href=/staff/5502773002/michael-leonard/ class="gnt_ar_by_a gnt_ar_by_a__fi">Michael Leonard</a><div class=gnt_ar_pb>Kent Weeklies</div></div><div class=gnt_ar_dt aria-label="Published: 10:10 p.m. ET Jan. 15, 2021 Updated: 10:32 p.m. ET Jan. 15, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/ data-ss-t="High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win" data-ss-d="The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=893568307789841&href=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F&text=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win&via=MyTownNEO" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win%20-%20from%20MyTownNEO&body=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win%0A%0AThe%20Bulldogs%20forced%2032%20turnovers%20and%20cruised%20to%20their%20fourth%20consecutive%20win%2C%20beating%20Mentor%2057-30%20Friday%20at%20home.%0A%0ACheck%20out%20this%20story%20on%20mytownneo.com%3A%20https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp gnt_em__el" aria-label="Video - Running duo connected by rope and friendship"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer aria-live=polite><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;oh-kent-weeklies-C6678&#34;,&#34;pn&#34;:&#34;MyTownNEO&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;sports/sportskind&#34;,&#34;byline&#34;:&#34;Sportskind&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-01-06T18:10:53Z&#34;,&#34;credit&#34;:&#34;Sportskind, USA TODAY&#34;,&#34;duration&#34;:59000,&#34;headline&#34;:&#34;Running duo connected by rope and friendship&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/0ec8d784-ef54-4903-b5c5-4486a75c85f7/d0bfa0b3-ae8c-44cb-9015-18bc27a5fa66/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=6565528002&#34;,&#34;id&#34;:&#34;6565528002&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/01/06/USAT/393e6ff1-32a3-47fa-84a2-376cdd0b9b5a-Courtesy_Nhi_Blansett_16x9.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-01-06T18:10:53Z&#34;,&#34;keywords&#34;:&#34;Cross Country Running,Arkansas,Video Syndication - USAT,Video Syndication – International&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/0ec8d784-ef54-4903-b5c5-4486a75c85f7/d0bfa0b3-ae8c-44cb-9015-18bc27a5fa66/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/sports/sportskind/2021/01/06/running-duo-connected-rope-and-friendship/6565528002/&#34;},&#34;promoBrief&#34;:&#34;High school freshman Paul Scott is able to compete safely in cross-country thanks to lightning fast fourth-grader, Rebel Hays.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-01-06T18:10:53Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;sports&#34;,&#34;subsection&#34;:&#34;sportskind&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;d7af364f-3ace-4a0f-b587-a73456ba683d&#34;,&#34;name&#34;:&#34;Cross Country Running&#34;},{&#34;id&#34;:&#34;d42910b3-8af0-4a2b-ba98-00fba6cbab7b&#34;,&#34;name&#34;:&#34;Arkansas&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;abb1b69c-143a-47e0-9004-50120aa6b80d&#34;,&#34;name&#34;:&#34;Video Syndication – International&#34;}],&#34;title&#34;:&#34;Running duo connected by rope and friendship&#34;,&#34;url&#34;:&#34;/videos/sports/sportskind/2021/01/06/running-duo-connected-rope-and-friendship/6565528002/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player" data-t-l=${tc}|tealplayer|automated-playerClose><svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/01/06/USAT/393e6ff1-32a3-47fa-84a2-376cdd0b9b5a-Courtesy_Nhi_Blansett_16x9.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Running duo connected by rope and friendship" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:366px src="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?width=300&height=366&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?width=600&height=732&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Mentor center Brooke Hickman presents Stow-Munroe Falls coach Bob Podges with a carnation before the Bulldogs' home game with the Cardinals Friday."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Mentor center Brooke Hickman presents Stow-Munroe Falls coach Bob Podges with a carnation before the Bulldogs' home game with the Cardinals Friday." data-c-credit="Photo Courtesy Of Timothy Howard"></div></figure><p class=gnt_ar_b_p>STOW — Prior to their game against Stow-Munroe Falls on Friday night, the Mentor girls basketball players let Bulldogs coach Bob Podges know they were thinking of him.</p><p class=gnt_ar_b_p>All five Mentor staters presented Podges with a red carnation before the game, as Podges is dealing with the recent death of his wife Josetta.</p><p class=gnt_ar_b_p>"That was a really classy gesture by them," Podges said. "The one thing this whole thing has taught me is the basketball community is very close. I can't tell you the number of messages of the support I've got over the last two weeks."</p><p class=gnt_ar_b_p>Podges' own players honored him by dominating the Cardinals.</p><p class=gnt_ar_b_p>Stow forced 20 turnovers in the first half while holding Mentor to only eight points. That suffocating defense led the Bulldogs to a 57-30 win at the James G. Tyree Gymnasium.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-sports-preps-basketball-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Since returning from their district-enforced COVID-19 pause Jan. 9, the Bulldogs (5-1) have won four games by an average margin of 28.5 points.</p><p class=gnt_ar_b_p>"We're getting into a rhythm right now," Podges said. "That first half was about as good as it gets, offensively and defensively. It was really hard for us to just practice and practice against each other all the time. We've really wanted to play someone else."</p><p class=gnt_ar_b_p>Although Mentor had a size advantage in the post, Stow's "pack line" defense shut down the Cardinals' inside game. Nearly every pass into the post seemed to result in the Bulldogs heading the other way with a turnover.</p><p class=gnt_ar_b_p>It also didn't hurt the Bulldogs that Lilee Carlson was feeling it.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:426px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/6d317e92-6f48-4720-a6c2-fcab001656f1-IMG_6575.JPG?width=300&height=426&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/01/16/NKNT/6d317e92-6f48-4720-a6c2-fcab001656f1-IMG_6575.JPG?width=600&height=852&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Stow-Munroe Falls guard Lilee Carlson passes the ball during the Bulldogs' 57-30 home win over Mentor Friday. Carlson led all scorers with 19 points."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Stow-Munroe Falls guard Lilee Carlson passes the ball during the Bulldogs' 57-30 home win over Mentor Friday. Carlson led all scorers with 19 points." data-c-credit="Photo Courtesy Of Timothy Howard"></div></figure><p class=gnt_ar_b_p>The Bulldogs' captain made several driving layups and three 3-pointers on her way to a game-high 19 points, despite playing scant minutes in the second half.</p><p class=gnt_ar_b_p>Podges said this was the kind of offensive output he wanted for Carlson this winter.</p><p class=gnt_ar_b_p>"She was really on tonight," Podges said. "She's been a true Stow girls basketball player since she was a freshman."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-sports-preps-basketball-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Carlson got plenty of help, especially on the defensive end. Mentor didn't score until center Brooke Hickman made a putback layup with 1:30 left in the first quarter.</p><p class=gnt_ar_b_p>That was Mentor's lone two-point field goal until the fourth quarter.</p><p class=gnt_ar_b_p>The Cardinals also got a 3-pointer from Sofia Kraska late in the first quarter and another from Kiley Kolschetzky midway through the second quarter, which accounted for all of Mentor's first-half points.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Every member of Stow's starting lineup came up with multiple steals and deflections on defense.</p><p class=gnt_ar_b_p>After leading 20-5 through one quarter, the Bulldogs opened the second quarter on a 10-0 run.</p><p class=gnt_ar_b_p>Podges said the best thing about Stow's defense was the intensity doesn't drop off when he goes to the bench.</p><p class=gnt_ar_b_p>"We have a lot of depth," Podges said. "It's something that surprises some people. The thing is we also have players who can go for the full game without subbing, so it's hard to bring them out."</p><p class=gnt_ar_b_p>Eight Bulldogs scored Friday, as Podges was able to get all varsity players playing time for the second consecutive game.</p><p class=gnt_ar_b_p>Forward Kristen Chmielewski did most of her damage in the second half. She finished with 12 points and guard Krista McDowell and forward Emily Ervin each scored six points for Stow off the bench.</p><p class=gnt_ar_b_p>Kraska led the Cardinals with six points on two 3-pointers.</p><p class=gnt_ar_b_p>Stow was set to host Ashtabula Lakeside on Saturday, but the game has been canceled due COVID concerns at Lakeside.</p><p class=gnt_ar_b_p>The Bulldogs will host Suburban League National Conference rival Nordonia on Martin Luther King Day. Varsity tip time is set for 6 p.m.</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/ data-ss-t="High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win" data-ss-d="The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=893568307789841&href=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F&text=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win&via=MyTownNEO" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win%20-%20from%20MyTownNEO&body=High%20school%20girls%20basketball%20%2F%20Stow%2057%2C%20Mentor%2030%3A%20Dominant%20defense%20leads%20Bulldogs%20to%20win%0A%0AThe%20Bulldogs%20forced%2032%20turnovers%20and%20cruised%20to%20their%20fourth%20consecutive%20win%2C%20beating%20Mentor%2057-30%20Friday%20at%20home.%0A%0ACheck%20out%20this%20story%20on%20mytownneo.com%3A%20https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-oh-kent-weeklies-C6678-poster-sports-preps-basketball-4 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.mytownneo.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fsports%2Fhigh-school%2Fbasketball%2F2021%2F01%2F15%2Fdominant-defense-leads-stow-girls-basketball-past-mentor%2F4171317001%2F&marketName=mytownneo&cta=Right-Rail" class=gnt_m_fs_a data-t-l=${tc}survey_click_story aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-poster_scroll-sports-preps-basketball-5 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/sports/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-oh-kent-weeklies-C6678-leaderboard_btf-sports-preps-basketball-6 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="MyTownNEO - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=|footer|about|careers>Careers</a> <a href=https://cm.mytownneo.com/accessibility/ class=gnt_ft_a data-t-l=|footer|about|accessibility>Accessibility</a> <a href=https://www.mytownneo.com/sitemap/ class=gnt_ft_a data-t-l=|footer|about|site-map>Site Map</a> <a href=https://www.publicnoticesohio.com/ class=gnt_ft_a data-t-l=|footer|about|legals>Legals</a> <a href=https://cm.mytownneo.com/ethical-conduct/ class=gnt_ft_a data-t-l=|footer|about|our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.mytownneo.com/terms/ class=gnt_ft_a data-t-l=|footer|about|terms-of-service>Terms of Service</a> <a href=https://cm.mytownneo.com/privacy/ class=gnt_ft_a data-t-l=|footer|about|privacy-policy>Privacy Policy</a> <a href=https://cm.mytownneo.com/privacy-policy/ class=gnt_ft_a data-t-l=|footer|about|california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=${tc}|footer|about|cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.mytownneo.com/contact-us class=gnt_ft_a data-t-l=|footer|support|contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=|footer|support|support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/Ohio/Kent class=gnt_ft_a data-t-l=|footer|support|advertise-your-business>Advertise Your Business</a> <a href=https://cm.mytownneo.com/advertising-terms-conditions class=gnt_ft_a data-t-l=|footer|support|advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=|footer|support|licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.mytownneo.com/ class=gnt_ft_a data-t-l=|footer|support|help-center>Help Center</a> <a href=https://cm.mytownneo.com/site-feedback/ class=gnt_ft_a data-t-l=|footer|support|feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://profile.mytownneo.com/newsletters/manage class=gnt_ft_a data-t-l=|footer|stay-connected|newsletters>Newsletters</a> <a href=http://www.facebook.com/MyTownNEO class=gnt_ft_a data-t-l=|footer|stay-connected|facebook>Facebook</a> <a href=http://www.twitter.com/MyTownNEO class=gnt_ft_a data-t-l=|footer|stay-connected|twitter>Twitter</a> <a href=https://user.mytownneo.com/user/enewspaper/ class=gnt_ft_a data-t-l=|footer|stay-connected|e-edition>E-Edition</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=|footer|our-partners|jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=|footer|our-partners|cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=|footer|our-partners|homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/ohwken class=gnt_ft_a data-t-l=|footer|our-partners|classifieds>Classifieds</a> <a href=https://www.billeriq.com/ebpp/GHM4902/Login class=gnt_ft_a data-t-l=|footer|our-partners|pay-your-ad-bill>Pay Your Ad Bill</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=|footer|our-partners|reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=|footer|our-partners|10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=|footer|our-partners|reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.mytownneo.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3b9875847.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3b664a966.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}|H1Nav|search| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z37Y48GqusgFivc0p61DKSGLeaK6I.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"High school girls basketball / Stow 57, Mentor 30: Dominant defense leads Bulldogs to win","description":"The Bulldogs forced 32 turnovers and cruised to their fourth consecutive win, beating Mentor 57-30 Friday at home.","url":"https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.mytownneo.com/story/sports/high-school/basketball/2021/01/15/dominant-defense-leads-stow-girls-basketball-past-mentor/4171317001/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?crop=1680,1680,x0,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG?crop=1680,945,x0,y204&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-01-16T03:10:12Z","dateCreated":"2021-01-16T03:10:12Z","dateModified":"2021-01-16T03:32:30Z","articleSection":"sports","publisher":{"@type":"Organization","name":"Kent Weeklies","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/mytownneo/images/site-nav-logo@2x.png"}},"author":["Michael Leonard"],"keywords":["access:metered","ssts:sports:high-school:basketball","type:story","tag:Girls High School Basketball","tag:Stow","tag:Mentor, OH","tag:Akron minorities","tag:Akron under $60k","tag:Akron 25-44","tag:Success","tag:Overall Positive","tag:Livonia High School Bulldogs"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Kent Weeklies - Unlimited Digital Access","productID":"mytownneo.com:standard"},"metadata":"{\"id\":\"4171317001\",\"siteCode\":\"NKNT\",\"contentSourceCode\":\"NKNT\",\"ssts\":\"sports:high-school:basketball\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/01/16/NKNT/6d317e92-6f48-4720-a6c2-fcab001656f1-IMG_6575.JPG","caption":"Stow-Munroe Falls guard Lilee Carlson passes the ball during the Bulldogs' 57-30 home win over Mentor Friday. Carlson led all scorers with 19 points.","copyrightHolder":"Photo courtesy of Timothy Howard"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/01/16/NKNT/0bbe6160-07fa-470a-a151-e4bf02a2ac1e-IMG_6573.JPG","caption":"Mentor center Brooke Hickman presents Stow-Munroe Falls coach Bob Podges with a carnation before the Bulldogs' home game with the Cardinals Friday.","copyrightHolder":"Photo courtesy of Timothy Howard"}]</script></body></html>