<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Faith, family, service highlight Hudson man's journey</title><meta property=og:title content="Faith, family, service highlight Hudson man's journey"/><link rel=amphtml href=https://amp.mytownneo.com/amp/7642240002 /><meta property=article:author content="Phil Keren"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.mytownneo.com /><link rel=preconnect href=https://user.mytownneo.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.mytownneo.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.mytownneo.com/NKNT-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z31a796c26.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z35ed89be3.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-0be9f6c1.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/ba4266d0-b904-40fc-bb81-53879e799ccb/ab7db254-2509-436e-af93-16ecd0a9506d/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7737229002" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="A longtime Hudson resident is marking his 95th birthday."/><meta property=og:description content="A longtime Hudson resident is marking his 95th birthday."/><meta property=fb:pages content=893568307789841 /><meta property=fb:app_id content=893568307789841 /><link rel=canonical href=https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/ /><meta property=og:url content=https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/ /><meta property=og:site_name content=MyTownNEO /><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?crop=1999,1125,x0,y132&width=1999&height=1125&format=pjpg&auto=webp"/><meta property=og:image:width content=1999 /><meta property=og:image:height content=1125 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?crop=1999,1125,x0,y132&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@MyTownNEO /><meta name=twitter:creator content=@MyTownNEO /><meta name=twitter:title content="Faith, family, service highlight Hudson man's journey"/><meta name=twitter:description content="A longtime Hudson resident is marking his 95th birthday."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label=MyTownNEO data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 284.5 45.22"><path d="M15.69 32.04L4.75 9.25v26.16H0V.66h5.67l12.42 26.27L30.5.66h5.57v34.75h-4.7V9.35L20.39 32.04zM53.7 37.5c-1.09 2.72-2.41 4.69-3.96 5.9s-3.3 1.81-5.24 1.81c-1.09 0-2.09-.14-3.01-.41-.92-.27-1.62-.55-2.09-.82l1.69-3.88c.41.17.85.34 1.33.51.48.17 1.04.26 1.69.26.99 0 1.9-.26 2.73-.79a5.53 5.53 0 002.02-2.58l1.18-2.76L38.73 9.66h5.26l8.43 19.21 7.36-19.21h5.16L53.7 37.5zm22.74-2.09V5.01h-11.7V.66H93.3v4.35H81.6v30.4zm27.69.51a13.5 13.5 0 01-6.82-1.71 12.33 12.33 0 01-4.7-4.75 13.87 13.87 0 01-1.71-6.92c0-2.59.57-4.9 1.71-6.92a12.33 12.33 0 014.7-4.75 13.5 13.5 0 016.82-1.71c2.55 0 4.83.57 6.82 1.71a12.4 12.4 0 014.7 4.75 13.9 13.9 0 011.71 6.92c0 2.59-.57 4.9-1.71 6.92a12.33 12.33 0 01-4.7 4.75 13.46 13.46 0 01-6.82 1.71m0-4.34c1.6 0 3.01-.38 4.24-1.15s2.19-1.83 2.89-3.19c.7-1.36 1.05-2.93 1.05-4.7s-.35-3.34-1.05-4.7a7.91 7.91 0 00-2.89-3.19 7.81 7.81 0 00-4.24-1.15c-1.6 0-3.01.38-4.24 1.15A7.98 7.98 0 0097 17.84a10.14 10.14 0 00-1.05 4.7c0 1.77.35 3.34 1.05 4.7.7 1.36 1.66 2.43 2.89 3.19s2.64 1.15 4.24 1.15m38.22 3.83l-5.72-20.18-5.57 20.18h-5.26l-7.87-25.75h4.95l5.73 20.74 5.62-20.74h4.95l5.73 20.74 5.77-20.74h4.8l-7.87 25.75zm20.85-14.26v14.26h-4.96V9.66h4.45l.36 3.99a9.47 9.47 0 013.58-3.24 10.16 10.16 0 014.91-1.25c2.89 0 5.23.95 7 2.84 1.77 1.89 2.66 4.57 2.66 8.05v15.38h-4.96v-15.4c0-2.08-.54-3.69-1.61-4.83a5.7 5.7 0 00-4.37-1.71 6.7 6.7 0 00-3.55.97 7 7 0 00-2.55 2.68 7.96 7.96 0 00-.96 4.01m45.22 14.26l-13.64-20.03v20.03h-8.74V.66h8.68l13.6 20.39V.66h8.78v34.75zm13.79 0V.66h23.97v7.62h-14.67v5.87h13.03v7.62h-13.03v6.03h15.48v7.61zm44.25.66a18.5 18.5 0 01-9.27-2.3 16.8 16.8 0 01-6.41-6.36 18.27 18.27 0 01-2.35-9.33c0-2.66.44-5.08 1.33-7.28a16.9 16.9 0 019.5-9.48 18.87 18.87 0 017.2-1.33c2.62 0 5.02.44 7.2 1.33a17.3 17.3 0 015.72 3.76 16.85 16.85 0 013.78 5.72c.89 2.2 1.33 4.62 1.33 7.28 0 3.51-.78 6.62-2.35 9.33a16.87 16.87 0 01-6.41 6.36 18.37 18.37 0 01-9.27 2.3m0-7.87c1.67 0 3.12-.43 4.37-1.28a8.7 8.7 0 002.94-3.55 12.22 12.22 0 001.07-5.29c0-2.01-.36-3.78-1.07-5.31a8.93 8.93 0 00-2.94-3.6 7.42 7.42 0 00-4.37-1.3c-1.67 0-3.13.43-4.37 1.3a8.93 8.93 0 00-2.94 3.6 12.34 12.34 0 00-1.07 5.31c0 2.01.36 3.77 1.07 5.29a8.63 8.63 0 002.94 3.55 7.5 7.5 0 004.37 1.28"/></svg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce gnt_n_mn_l__se" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/obituaries/ data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.mytownneo.com/user/enewspaper/ data-t-l=:n|v|c|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://classifieds.gannettclassifieds.com/marketplace/knt/category/Legals data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Kent" title="Weather in Kent" data-t-l=:n|v|c|weather></a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-oh-kent-weeklies-C6678-high_impact-news-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=News data-c-ssts=NEWS></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>Faith, family, service highlight Hudson man's journey</h1><h2 class=gnt_ar_shl>John Ricchiuto celebrates 95th birthday</h2><div class=gnt_ar_by><a href=https://www.beaconjournal.com/staff/5595649002/phil-keren/ class="gnt_ar_by_a gnt_ar_by_a__fi">Phil Keren</a><div class=gnt_ar_pb>Akron Beacon Journal</div></div><div class=gnt_ar_dt aria-label="Published 7:56 a.m. ET Jun. 26, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/ data-ss-t="Faith, family, service highlight Hudson man's journey" data-ss-d="A longtime Hudson resident is marking his 95th birthday."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=893568307789841&href=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F&text=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey&via=MyTownNEO" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey%20-%20from%20MyTownNEO&body=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey%0A%0AA%20longtime%20Hudson%20resident%20is%20marking%20his%2095th%20birthday.%0A%0ACheck%20out%20this%20story%20on%20mytownneo.com%3A%20https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp" aria-label="Video - How Navy SEALS and scientists are saving the ocean"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;oh-kent-weeklies-C6678&#34;,&#34;pn&#34;:&#34;MyTownNEO&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;lifestyle/humankind&#34;,&#34;byline&#34;:&#34;Earthkind&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-06-17T20:36:24Z&#34;,&#34;credit&#34;:&#34;Earthkind, USA TODAY&#34;,&#34;duration&#34;:45000,&#34;headline&#34;:&#34;How Navy SEALS and scientists are saving the ocean&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/ba4266d0-b904-40fc-bb81-53879e799ccb/ab7db254-2509-436e-af93-16ecd0a9506d/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=7737229002&#34;,&#34;id&#34;:&#34;7737229002&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/06/17/USAT/b227e8b0-3836-4b23-ae11-90a1038d405f-Earthkind_Force_Blue__16x9_Thumbnail.jpeg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-06-17T20:36:24Z&#34;,&#34;keywords&#34;:&#34;Oceans and Seas,Overall Positive,Climate Change,Coral Reefs&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/ba4266d0-b904-40fc-bb81-53879e799ccb/ab7db254-2509-436e-af93-16ecd0a9506d/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/life/humankind/2021/06/17/how-navy-seals-and-scientists-saving-ocean/7737229002/&#34;},&#34;promoBrief&#34;:&#34;These scientists are teaming up with American heroes to save the ocean. Force Blue is protecting the planet one coral at a time.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-06-17T20:36:24Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;life&#34;,&#34;subsection&#34;:&#34;humankind&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;8cea8c69-8091-4aa7-82b7-3e303e57af98&#34;,&#34;name&#34;:&#34;Oceans and Seas&#34;},{&#34;id&#34;:&#34;7095bb07-b172-434b-a4eb-8856263ad949&#34;,&#34;name&#34;:&#34;Overall Positive&#34;},{&#34;id&#34;:&#34;5e28ddaf-145d-4eb7-9f85-abda05e32ffc&#34;,&#34;name&#34;:&#34;Climate Change&#34;},{&#34;id&#34;:&#34;c1de03c1-ba71-49a6-98b9-27f2bb98faea&#34;,&#34;name&#34;:&#34;Coral Reefs&#34;}],&#34;title&#34;:&#34;How Navy SEALS and scientists are saving the ocean&#34;,&#34;url&#34;:&#34;/videos/life/humankind/2021/06/17/how-navy-seals-and-scientists-saving-ocean/7737229002/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/06/17/USAT/b227e8b0-3836-4b23-ae11-90a1038d405f-Earthkind_Force_Blue__16x9_Thumbnail.jpeg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="How Navy SEALS and scientists are saving the ocean" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:461px src="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?width=660&height=461&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?width=1320&height=922&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="John Ricchiuto smiles as he reflects on his 95 years of life experience during an interview, Tuesday, June 15, 2021, in Hudson, Ohio."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="John Ricchiuto smiles as he reflects on his 95 years of life experience during an interview, Tuesday, June 15, 2021, in Hudson, Ohio." data-c-credit="Jeff Lange, Akron Beacon Journal"></div></figure><p class=gnt_ar_b_p>HUDSON —  In 1979, John Ricchiuto walked into a home on Brewster Drive and took a seat.</p><p class=gnt_ar_b_p>Up until then, Ricchiuto's wife Rosemarie had looked at many houses before deciding she liked the one in Hudson and encouraged him to take a look. It didn't take long to persuade Ricchiuto they had found their new home.</p><p class=gnt_ar_b_p>"I went in and sat down," said Ricchiuto, "I said to my wife, 'honey, do you like the house?' She said 'oh yeah.' I said, 'well, buy it.'"</p><p class=gnt_ar_b_p>Forty-two years later, Ricchiuto — who is celebrating his 95th birthday — still lives in the same home and is active with his church, St. Mary Parish on North Main Street, participating in discussion groups and maintaining bonds with family and friends. </p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Ricchiuto smiled and laughed as he shared stories and life philosophies with the <em>Hub-Times</em> in a meeting at the gazebo in downtown Hudson. He said his journey has been guided by faith, family, a professional career as an engineer and public service as a council member in two different communities.</p><h3 class=gnt_ar_b_h2>Father instilled maturity in him</h3><p class=gnt_ar_b_p>Ricchiuto was born on June 26, 1926, in Cleveland and grew up near Shaker Heights. He said his father, an Italian immigrant who served in World War I, provided him with a good balance of freedom and restrictions.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>"He always disciplined me in the sense that he drew a line and I couldn't cross that line, but within that line, I had all the freedom in the world," Ricchiuto said.</p><p class=gnt_ar_b_p>He praised his father for instilling a sense of maturity in him. Ricchiuto's mother died when he was 7. His father remarried, and Ricchiuto said his stepmother "was a beautiful woman and she completed what my mother started."</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Ricchiuto attended high school at a college preparatory facility for three days, but recalled "something in the environment didn't agree with me," and he transferred to a technical school without his father's knowledge. A couple weeks later, his dad asked him about school, and Ricchiuto surprised him when he said he switched to the technical institution. His education there sparked his interest in becoming an electrical engineer. </p><p class=gnt_ar_b_p>He was inducted into the U.S. Navy in 1944 and served for 18 months. At the age of 20, he was stationed on the Marshall Islands for six months as a supervisor of communications, and supervised a group of five or six.</p><p class=gnt_ar_b_p>"[World War II] was literally over with by then," he said.</p><h3 class=gnt_ar_b_h2>Marriage, public service</h3><p class=gnt_ar_b_p>Thanks to the GI Bill, Ricchiuto went to Fenn College (which is now Cleveland State University) and earned a bachelor's degree in electrical engineering.</p><p class=gnt_ar_b_p>After college, Ricchiuto worked for a power company and then went into private industry, working as an engineer at H.K. Ferguson in Cleveland. He and Rosemarie were married in 1950, and lived in Maple Heights, where they raised three children — Jack, Barb and Bob.</p><p class=gnt_ar_b_p>The couple had been together for 66 years when Rosemarie died in 2017.</p><p class=gnt_ar_b_p>"She was a good woman, a good person," Ricchiuto said.</p><p class=gnt_ar_b_p>Longtime friend Karen Baglieri shared that John gave Rosemarie a rose each week during the final two decades of their marriage.</p><p class=gnt_ar_b_p>Baglieri added she thought it was "romantic."</p><p class=gnt_ar_b_p>"Once I committed myself to it, I did it," Ricchiuto said.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>In the 1970s, Ricchiuto ran for Maple Heights Council and initially won by five votes. When his opponent sought a recount, the results ended in a tie and Ricchiuto lost on a coin flip. A ballot that was disqualified had an "X" next to Ricchiuto's name, but half of an "X" mark next to his opponent's name. Looking back, Ricchiuto said his life was changed "by half of an 'X.'"</p><p class=gnt_ar_b_p>About a year later, Ricchiuto said he received a phone call informing him that the council member in his district had resigned. He was appointed to the position and ended up serving on Maple Heights Council for several years. He served on council in the 1970s and said his tenure included passage of a bond issue to construct a new, larger library and spearheading the adoption of two charter changes.</p><h3 class=gnt_ar_b_h2>Move to Hudson in 1979</h3><p class=gnt_ar_b_p>When Ricchiuto's job was transferred from H.K. Ferguson in Cleveland to Hale & Kullgren in Akron, Ricchiuto said he, Rosemarie and son Bob, moved to Brewster Drive in Hudson in 1979. The other two children, Jack and Barb, had moved out before the family relocated to Hudson.</p><p class=gnt_ar_b_p>Ricchiuto said Hudson is "a nice city" with "a lot of good people" and he's enjoyed living in the municipality.</p><p class=gnt_ar_b_p>Ricchiuto served as a trustee on the Hudson Township Board of Trustees for several years, including a stint as president. As a board member, he guided an expansion of the fire station/EMS building on Oviatt Street, with a bond issue being approved by voters for the project.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>The project "came in on time and within budget, which you don't hear too often," Ricchiuto said. "It was a good thing. It's still there. They haven't expanded it, so apparently whatever we decided back then is still valid today."</p><p class=gnt_ar_b_p>Ricchiuto was on the board of trustees when the village of Hudson and Hudson Township merged to become a city in 1995. He noted he agreed with the merger and promoted the idea.</p><p class=gnt_ar_b_p>"We turned over a good fire department," Ricchiuto said. "We turned over a good EMS department. Our police department was up-to-date in terms of technology. We weren't a burden to the village when the township became a city."</p><p class=gnt_ar_b_p>The merger allowed the newly formed city the ability to tax and enact its own ordinances.</p><p class=gnt_ar_b_p>After the merger, Ricchiuto served on an interim council for six months, then ran for council and lost. He noted he walked door-to-door to meet voters as he campaigned and said the time spent pounding the pavement helped his waistline.</p><p class=gnt_ar_b_p>"I couldn't lose," Ricchiuto said, "If I lost the election, so what? At least I was in good shape when it was all done."</p><p class=gnt_ar_b_p>He said he was asked to run again and "toyed with the idea," but decided against it.</p><h3 class=gnt_ar_b_h2>Challenges of elected office</h3><p class=gnt_ar_b_p>When one serves in elected office, Ricchiuto said, it's important to "stay close to the people" and "reflect what people want." Sometimes that meant having tough conversations with his constituents.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>While serving on Maple Heights Council, Ricchiuto received a call from a resident who said he had 3 feet of water in his basement. He and his campaign manager walked down the road and the frustrated resident yelled at him while standing almost nose-to-nose with him.</p><p class=gnt_ar_b_p>Ricchiuto said he told the man, "you have the right to holler at me."</p><p class=gnt_ar_b_p>After they left the house, Ricchiuto said his campaign manager asked him how he handled that difficult situation.</p><p class=gnt_ar_b_p>"The man had to express himself," Ricchiuto said. "I think politicians don't do that. They don't get down to the nitty-gritty to ultimately reflect on what they ought to do in the bigger picture."</p><p class=gnt_ar_b_p>He remarked he felt people should be "diligent" about who they vote for in local elections "because those are the people who potentially can hold a federal office, which is very important."</p><h3 class=gnt_ar_b_h2>'Adopted dad'</h3><p class=gnt_ar_b_p>Ricchiuto said he's always liked people and it certainly seems that outlook has served him well in his life.</p><p class=gnt_ar_b_p>Baglieri said she's been friends with Ricchiuto for about 25 years. She and her husband previously owned the McDonald's in Hudson and Ricchiuto was a regular customer. The friendship began when Ricchiuto would speak with Baglieri about the latest encyclical from the Pope (teachings from the church) that he was reading.</p><p class=gnt_ar_b_p>"Probably in the last 10 years it's been…a really in-depth friendship," Baglieri shared. "I went through a really rough time and John was my rock."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-native-article_link-news-7 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Noting her father died when she was 15 months old, Baglieri said she considers Ricchiuto to be her "adopted dad."</p><p class=gnt_ar_b_p>Baglieri added she recently spoke with a mutual acquaintance who talked about a conversation he'd had with Ricchiuito. She said the man shared that talks with Ricchiuto made want him to be a better husband and father.</p><p class=gnt_ar_b_p>"The way he leads his life, he inspires other people to lead better lives and to be better themselves, just by virtue of who he is," Baglieri said.</p><p class=gnt_ar_b_p>She called her friend "a remarkable man."</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:328px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/8a70fdc6-5e16-4619-9a97-40319da8365b-95_birthday_2.JPG?width=300&height=328&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/06/21/NABJ/8a70fdc6-5e16-4619-9a97-40319da8365b-95_birthday_2.JPG?width=600&height=656&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="John Ricchiuto chats with the Hudson Hub-Times during an interview, Tuesday, June 15, 2021, in Hudson, Ohio. Ricchiuto turns 95 on June 26."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="John Ricchiuto chats with the Hudson Hub-Times during an interview, Tuesday, June 15, 2021, in Hudson, Ohio. Ricchiuto turns 95 on June 26." data-c-credit="Jeff Lange, Akron Beacon Journal"></div></figure><h3 class=gnt_ar_b_h2>Faith central to Ricchiuto's life</h3><p class=gnt_ar_b_p>Faith is important to Ricchiuto. He's been a member of St. Mary Parish on N. Main Street since 1979 and served on the parish council for a period of time.</p><p class=gnt_ar_b_p>He's had faith-based meetings with groups of men since 1964 when he started a prayer group at his place of employment. Today, Ricchiuto said he still meets with three different men's groups, including one where he fixes pancakes for everyone to enjoy while they have their discussion.</p><p class=gnt_ar_b_p>The men, Ricchiuto said, talk about "our spiritual life [and] how we respond to people."</p><p class=gnt_ar_b_p>He is also working with two other men to offer a new course on Christianity at St. Mary Parish. While acknowledging there is a lot of work involved, Ricchiuto said, "I've got to keep going."</p><p class=gnt_ar_b_p>Sometimes people talk with Ricchiuto about their challenges in life and seek his guidance. He said he tells them to "do the best they can, pray," and follow the principles of the acronym LIPO: Let It Play Out.</p><p class=gnt_ar_b_p>"I think in many instances, we are in a position to let things play out," Ricchiuto stated.</p><p class=gnt_ar_b_p>As he sat in the gazebo in downtown Hudson visiting with the <em>Hub-Times</em>, Ricchiuto shared a prayer reading from the Liturgy of the Hours that he viewed earlier that day: "Direct my thoughts, feelings and actions of this dayelp me to follow your providential guidance."</p><p class=gnt_ar_b_p>After reflecting on the passage, Ricchiuto said he felt those words described his own journey. </p><p class=gnt_ar_b_p>"I think that's been my life," he said. "I've followed His providential guidance… I believe He guides us. I do…I have no resentment in my life, none at all."</p><p class=gnt_ar_b_p><em>Reporter Phil Keren can be reached at pkeren@thebeaconjournal.com, or on Twitter at @keren_phil.</em></p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/ data-ss-t="Faith, family, service highlight Hudson man's journey" data-ss-d="A longtime Hudson resident is marking his 95th birthday."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=893568307789841&href=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F&text=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey&via=MyTownNEO" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey%20-%20from%20MyTownNEO&body=Faith%2C%20family%2C%20service%20highlight%20Hudson%20man's%20journey%0A%0AA%20longtime%20Hudson%20resident%20is%20marking%20his%2095th%20birthday.%0A%0ACheck%20out%20this%20story%20on%20mytownneo.com%3A%20https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-oh-kent-weeklies-C6678-poster-news-8 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.mytownneo.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F&marketName=mytownneo&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-kent-weeklies-C6678-poster_scroll-news-9 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-oh-kent-weeklies-C6678-leaderboard_btf-news-10 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="MyTownNEO - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.mytownneo.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.mytownneo.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.publicnoticesohio.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.mytownneo.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.mytownneo.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.mytownneo.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.mytownneo.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.mytownneo.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/Ohio/Kent class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.mytownneo.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.mytownneo.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.mytownneo.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://profile.mytownneo.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=http://www.facebook.com/MyTownNEO class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=http://www.twitter.com/MyTownNEO class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=https://user.mytownneo.com/user/enewspaper/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:e-edition>E-Edition</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/ohwken class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.mytownneo.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z35ed89be3.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=vdscta><div class=gnt_em_vp_sbcta><a class=gnt_em_vp_sbcta_sb data-t-l=":d|d|auto subscribe|${t}" target=_blank rel=noopener href="https://subscribe.mytownneo.com/specialoffer?gps-source=IUXPLAYEROVERLAY&itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp&onSuccessRedirectURL=https%3A%2F%2Fwww.mytownneo.com%2Fstory%2Fnews%2F2021%2F06%2F26%2Ffaith-family-service-highlight-hudson-mans-journey%2F7642240002%2F">Subscribe</a> <a class=gnt_em_vp_sbcta_dt data-t-l=":d|d|auto included|${t}" target=_blank rel=noopener href="https://cm.mytownneo.com/whats-included-subscribe?itm_campaign=subtoturnoff&itm_medium=IUX&itm_source=videoautoplay&itm_content=videoavp">What's included?</a></div>|styles|.gnt_em_vp_sbcta{display:flex;flex-direction:column;text-align:center;position:absolute;top:25px;z-index:4;width:400px;height:225px;background:#000;color:#fff;font-family:'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:antialiased;-moz-osx-font-smoothing:grayscale;-webkit-user-select:none;user-select:none}.gnt_em_vp_sbcta::before{content:'Autoplay videos can be distracting. Make them go away.';order:-1;margin:38px 0 0;padding:0 55px;font-size:16px;line-height:20px;font-weight:700}.gnt_em_vp_sbcta::after{content:'Subscribers can turn off autoplay video - and more!';order:-1;margin:6px 0 12px;padding:0 88px;font-size:14px;line-height:16px}.gnt_em_vp_sbcta_sb{width:88px;height:30px;margin:0 156px 9px;border-radius:2px;background:#fff;color:#1665cf;font:700 14px/30px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;-webkit-font-smoothing:initial;-moz-osx-font-smoothing:initial;text-decoration:none;text-align:center}.gnt_em_vp_sbcta_sb:hover{color:#0a32a0}.gnt_em_vp_sbcta_dt{width:max-content;margin:0 auto;padding:0 2px;outline-offset:1px;color:#fff;font:12px/14px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_em_vp_sbcta_dt:hover{color:#e0e0e0}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3wAmypFCLmkVWWkAooF0r2FMo.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"Faith, family, service highlight Hudson man's journey","description":"A longtime Hudson resident is marking his 95th birthday.","url":"https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.mytownneo.com/story/news/2021/06/26/faith-family-service-highlight-hudson-mans-journey/7642240002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?crop=1395,1395,x200,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG?crop=1999,1125,x0,y132&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-06-26T11:56:05Z","dateCreated":"2021-06-26T11:56:05Z","dateModified":"2021-06-26T11:56:05Z","articleSection":"news","publisher":{"@type":"Organization","name":"Akron Beacon Journal","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/mytownneo/images/site-nav-logo@2x.png"}},"author":["Phil Keren"],"keywords":["access:metered","ssts:news","type:story","tag:Hudson, OH","tag:Overall Positive"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Akron Beacon Journal - Unlimited Digital Access","productID":"mytownneo.com:standard"},"metadata":"{\"id\":\"7642240002\",\"siteCode\":\"NKNT\",\"contentSourceCode\":\"NABJ\",\"ssts\":\"news\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/06/21/NABJ/d88294cf-026e-41b2-9eb9-96f81cd819c2-95_birthday_1.JPG","caption":"John Ricchiuto smiles as he reflects on his 95 years of life experience during an interview, Tuesday, June 15, 2021, in Hudson, Ohio.","copyrightHolder":"Jeff Lange, Akron Beacon Journal"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/06/21/NABJ/8a70fdc6-5e16-4619-9a97-40319da8365b-95_birthday_2.JPG","caption":"John Ricchiuto chats with the Hudson Hub-Times during an interview, Tuesday, June 15, 2021, in Hudson, Ohio. Ricchiuto turns 95 on June 26.","copyrightHolder":"Jeff Lange, Akron Beacon Journal"}]</script></body></html>